1.15 support

1.15 support

EDIT: 1.15.1 is now fully supported including blocks on the factions server.

You can now also join with the latest version of minecraft. 1.15 However we still recommend playing on 1.14.4 for the best experience. (1.15 blocks and other features are not yet supported)

Leave a Reply

Your email address will not be published. Required fields are marked *